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Introduction

1 INTRODUCTION

Symprex Out-of-Office Manager allows a user, such as a receptionist or team
leader, to modify the out-of-office settings for a mailbox or group of mailboxes.

Symprex Out-of-Office Manager helps to ensure that out-of-office settings are
always correct and up-to-date for all users. It also improves security, because
users can now be allowed to work with out-of-office information of other users
without giving them access to the mailbox contents of those users.

1.1 System Requirements

Symprex Out-of-Office Manager requires:

e When installing on workstation:
Microsoft Windows NT4 (SP3 or later), 2000 or XP
Microsoft Outlook 2000, 2002 (SP3 or later), 2003 or 2007

¢ When installing on server:
Microsoft Windows Server NT4 (SP3 or later), 2000 or 2003
Microsoft Exchange 5.5, 2000 or 2003

e 10 MB free hard-disk space
e 800 x 600 or higher screen resolution
e Supports use via terminal services on the above listed server platforms

This software currently does not support installation on Windows Vista.
This software currently does not support use with Exchange 2007.

Symprex Out-of-Office Manager can work with out-of-office information for any
version of Outlook, but requires one of the above Outlook versions installed on
the machine it is installed on.

1.2 Installation Notes

To allow ordinary domain users to access the out-of-office information on your
Exchange server, Out-of-Office Manager communicates with Exchange server
through a service running locally on the client machine. Before you can use the
application, this service needs to be configured to run using a domain account
that must have certain administrative permissions in the domain and on your
Exchange server.

Please see §3 for information on how to configure the Out-of-Office Manager
service.

Please see §4 for information on required permissions and how to assign them
to your service account.
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2 TUTORIAL

2.1 Getting Started

Symprex Out-of-Office Manager is started by clicking its icon in the Windows
program group. If the application is running in evaluation mode, a window will
be displayed advising you of the number days remaining in the evaluation
period. If you have purchased a license, you can enter it by clicking the Enter
Registration... button.

After the splash screen has been displayed, you may be required to select the
profile of the Exchange user you wish to connect as. Once successfully logged
on, the main application window will be opened.

Before you start the application, you must have configured and started the
Symprex Out-of-Office Manager service (see §3 and §4 for more information).

2.2 The Main Application Window

The main application window is split in to two parts.
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The left-hand side of the window displays a tree of your Exchange system,
including all address lists, distribution lists and mailboxes. Expanding the nodes
(either by double-clicking the node itself or clicking the “+” box to the left of the
node) will reveal the contents of that node.

The right-hand side of the window displays the out-of-office settings for the

currently selected Mailbox in the Exchange system tree (when a non-mailbox
node is selected, the controls will be disabled).
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To adjust the settings for the selected user, set the controls as required and
click the Apply button. Alternatively, to reload the current settings, click the
Refresh button.

2.3 Menus

2.3.1 File Menu

The File menu contains the following items:

e Options — displays the Options dialog (see §2.4).
e Connect to Service — manually connect application to service. See §3.1.
e Exit — closes the application.

2.3.2 Group Menu

The Tools menu contains the following items:
e Settings — displays the Group settings dialog (see §2.5).

2.3.3 Help Menu

The Help menu contains the following items:

e Contents — displays the help system for the application.

e Symprex Web Site — opens your default Internet browser at the Symprex
Web Site homepage.

e Symprex Support Page — opens your default Internet browser at the
Symprex support web page.

e About — displays the About box for the application.

2.3.4 Context-Sensitive Menu

The context-sensitive menu is displayed when an item in the explorer is right-
clicked. The menu contains the following items:

e Group Settings... - displays the Group Settings dialog (see §2.5).
e Refresh... - refreshes the selected item.

2.4 Options

The Options dialog is opened by selecting the File > Options... menu item. The
following options are available:

e Disable Splash Screen (Registered Version only) — prevents the splash

screen from being displayed when the application is started. This setting
only has effect in the registered version of the application.
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e Use Current Profile — when checked, the application will log on your
Exchange Server using the current mail profile if such a profile is
currently logged on (for example, if you are using Microsoft Outlook). If a
profile is not available or this option is not checked, the “Choose Profile”
dialog is displayed when the application starts.

2.5 Group Settings

The Group Settings dialog allows you to apply the same settings to a large
group of users. To open it, select the appropriate group and either select the
Group > Settings... menu item or right-click the node and select Group
Settings.
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When first opened, the dialog will begin building the list of mailboxes and the
setting for each one. This process can be interrupted by clicking the Cancel
button.

To apply settings to the group, first select which mailboxes should be included;
only the checked items will be modified. To select or de-select an item, click the
box to the left of the mailbox name. Clicking the All button will select all items in
the list, the None button will de-select all items in the list, and Invert will set all
selected items to be de-selected and vice versa.

Once the appropriate items are selected, set the controls below the list. When

ready, click the Apply button to apply the changes. This process can be
cancelled at any time by clicking the Cancel button, although it should be noted
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that one a mailbox has been modified, clicking the Cancel button will not set it
back to its original state.

Note Once applying the settings has been completed (or cancelled), the list will
be rebuilt to confirm the changes were applied on the server.
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3 THE SERVICE COMPONENT

To allow ordinary domain users to access the out-of-office information on your

Exchange server, Out-of-Office Manager communicates with Exchange server

through a service running locally on the client machine. Before you can use the
application, this service needs to be configured to run using a domain account

that must have certain administrative permissions on the local machine and on
your Exchange server.

Please see §4 for information on required permissions and how to assign them
to your service account.

To configure the service under Windows NT 4.0:

Open Control Panel.

Open Services.

Locate the “Symprex Out-of-Office Manager Server” service.
Click the Startup button.

Select the This Account option.

Select the appropriate account and enter the password.
Click OK.

N gk owN=

To configure the service under Windows 2000 or XP:

Open Control Panel.

Open Administrative Tools.

Open Services.

Locate and open the “Symprex Out-of-Office Manager Server” service.
Select the Log On tab.

Select the This Account option.

Select the appropriate account and enter the password.

Click OK.

©NOoOOA WD~

3.1 How the Application Connects to the Service

When the application first starts, it will attempt to establish a connection to the
service. If the service is not running, a time-out will occur after 5 seconds. If the
service is then started through Control Panel, a connection can be manually
established by selecting the File > Connect to Service menu item. This will
also time-out after 5 seconds if the connection is not made.
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4 REQUIRED SERVICE ACCOUNT PERMISSIONS

Before you can use Symprex Out-of-Office Manager, you need to configure the
Symprex Out-of-Office Manager service (see §3). The account you specify as
service account need to have permissions on Exchange 5.5, 2000 and 2003,
and in the domain, as described below.

4.1 Exchange 5.5 Account Permissions

To make sure your service account has the required permissions on Exchange
5.5, follow these steps:

Step 1
Open Microsoft Exchange Administrator, then:

e Open the Options dialog from the Tools menu.

e Make sure that the Display rights for roles on Permissions page is
checked.

Dptions E3

Zuto Maming  Permizsions | File Fnrmatl

—windows MT domain defaults
Default "Windows NT domain
DOMAIN =]

% Select user accounts from ‘Windows NT domain of connected Exchange Server

" Select user accounts from default Windows NT domain

" Show Permissions page for all objects

¥ Display rights for roles on Permissions page

[ Delete primany Windows MT account when deleting mailbox

¥ Ty to find matching *Windows NT account when creating mailbos:

QK I Cancel Apply Help

Step 2
Click the domain container, then:

e Open the Properties dialog from the File menu.

(see dialog top of next page)
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‘% Microsoft Exchange Administrator
File Edt “iew Toolz Window Help

|SERVER =l EiE EN T AR

% Symprex Ltd Dizplay Name » I Business Phone
Addrezz Book Wievs Configuration
Folders Fecipients
i Global Address List
+ & A
Step 3

Select the Permissions tab in the domain properties dialog, then, for your
account:

e Make sure Mailbox Owner is checked.
e Make sure Logon Rights is checked.

Gereral Permissionsl
© DOMAIN

—windows NT accountz with permizsions

Bemove |
[

Roles: Rights

I Service Account Admin. j Send bz
Mailbox Dwner
Logon Rights i
Replication hd|

QK I Cancel | el | Help |

Step 4
Finally:
e Your account must be a member of the Domain Admins group.

Your account now has the required permissions.
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4.2 Exchange 2000/2003 Account Permissions

To make sure your service account has the required permissions on Exchange
2000 or 2003, follow these steps:

Step 1
Open Exchange System Manager, then:

e Select your server (or mailbox store).
¢ Right-click and select Properties to open the Properties dialog.

Step 2
Select the Security tab in the server (or mailbox store) properties dialog, then:

e Add or select your account.
e Allow the Administer information store right.

seRveR 21|
Diagnostice Logging I Public Folder Refernalz I Dretails I Directony Access
Gerneral I Locales I b ailbios b anagement
RPCHTTP | Policies  Sesuity | FulTestindesing | Manitoring
Group or user names:
ﬁ: Domain Adming [STMPREXNDomain Adminz) ;I
ﬂi Enterprize Adming [SYMPREXME nterprize Admins)
ﬁ: Ewerone J
ﬂi Exchange Domain Servers [SYMPREXME xchange Domain Seryv...
€7 James Dean [ide@symprex. dom)
% e st s 1 s e [ |
Agd... | Bemove |
Permizsions for James Dean Al Deny
Fiead metabaze properties a a :I
Adminigter information store a
Create named properties in the information store [ a
Wi information store status a a
Receive Az a a J
Send Az O O LI
For special permiszions or for advanced settings, SikErzed |
click. Advanced. —

0k I Cancel | Apply | Help |

Repeat the above steps for appropriate servers (or mailbox stores) as required.
Step 3

Finally, your service account must be a member of the Domain Admins group,
or it must have full administrator rights on the local machine.

Your account now has the required permissions.
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5 CONTACTING SYMPREX

5.1 Visit our Web Site

Our web site provides general information about Symprex and our products:
http://www.symprex.com

If you experience technical problems with one of our products, please visit our
support page:
http://www.symprex.com/support

5.2 Contact us by e-mail

Please e-mail general enquiries about Symprex or our products to:
info@symprex.com

Please e-mail sales enquiries to:
sales@symprex.com

Please e-mail support enquiries to:
support@symprex.com

5.3 Contact your local reseller

Symprex has partners and resellers in most countries. You can find your local
reseller here:
http://www.symprex.com/resellers
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