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1 INTRODUCTION 
Symprex Mailbox Manager allows you to update the properties, or account 
information, of either an individual mailbox or a group of mailboxes. Group 
settings may be exported to Microsoft Excel or printed directly to any printer. 
 
Symprex Mailbox Manager is the perfect tool for maintaining correct account 
information on all the mailboxes in your Exchange installation. Authentication 
complies with Exchange/Windows/NT security, and it does not require use of 
Exchange Admin facilities. 

1.1 System Requirements 

Symprex Mailbox Manager requires: 
 

• When installing on workstation:

• 

 
Microsoft Windows 2000, XP, Vista or 7 
Microsoft Outlook 2000, 2002, 2003, 2007 or 2010 (32-bit) 
When installing on server:

• 10 MB free hard-disk space 

 
Microsoft Windows Server 2000, 2003 or 2008 
Microsoft Exchange Server 2000, 2003, 2007 or 2010 

• 800 x 600 or higher screen resolution 
• Supports use via terminal services on the above listed server platforms 

1.2 Permissions Requirements 

Symprex Mailbox Manager requires you to be logged on to Windows with a 
domain account that must have permissions to change account information on 
your Exchange server/in Active Directory (see §3). 
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2 TUTORIAL 

2.1 Getting Started 

Symprex Mailbox Manager is started by clicking its icon in the program group. If 
the application is running in evaluation mode, a window is displayed advising 
you the number days remaining in the evaluation period. If you have purchased 
a license, you can enter it by clicking the Enter Registration… button. 
 
After the splash screen has been displayed, you may be required to select the 
profile of the Exchange user you wish to connect as. Once successfully logged 
on, the main application window will be opened. 
 
Symprex Mailbox Manager requires you to be logged on to Windows with a 
domain account that must have permissions to change account information on 
your Exchange server/in Active Directory (see §3). 

2.2 The Main Application Window 

The main application window is split in to two parts. 
 

 
 
The left-hand side of the window displays a tree of your Exchange system, 
including all address lists, distribution lists and mailboxes. Expanding the nodes 
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(either by double-clicking the node itself or clicking the “+” box to the left of the 
node) will reveal the contents of that node. 
 
The right-hand side of the window displays the properties for the currently 
selected mailbox in the Exchange system tree (when a non-mailbox node is 
selected, the controls will be disabled). This display has five tabs: 
 

• The General tab displays the general mailbox information, such as the 
user’s full name, alias, personal contact information and business details. 

• The Phone/Notes tab displays all the mailboxes telephone numbers and 
notes about the mailbox. 

• The E-mail Address tab lists the valid email addresses for the mailbox, 
such as their external SMTP address. 

• The Custom Attributes tab lists the custom attributes for the mailbox. 
• The System Information tab shows system information for the mailbox. 

 
Most of the properties of the mailbox may be modified in the window; properties 
that cannot be modified are shown with a darkened background. 
 
Note The Assistant and Primary Business Phone properties are duplicated 
between the General and Phone/Notes tab. Updating the property on one tab 
will update it on the other automatically. 
 
Once the desired changes have been made, click the Apply Changes button to 
apply the changes to the mailbox. To refresh the properties, click the Refresh 
button.  

2.2.1 Custom Attributes 

The Custom Attributes for a mailbox allow the administrator to record any 
additional pieces of information about a particular mailbox, e.g. the type and 
registration of company car. To make these attributes more usable, Mailbox 
Manager allows the label for each attribute to be modified. To rename an 
attribute, double-click its label on the Custom Attributes tab and adjust the name 
as desired. 
 
Note Renaming of the Custom Attribute fields is unique for each Windows user; 
that is, the names are not stored as part of the information in the mailbox. 

2.3 Menus 

2.3.1 File Menu 

The File menu contains the following items: 
 

• Options – displays the Options dialog (see §2.4). 
• Exit – closes the application. 
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2.3.2 Group Menu 

The Tools menu contains the following items: 
 

• Settings – displays the Group settings dialog (see §2.5). 

2.3.3 Help Menu 

The Help menu contains the following items: 
 

• Contents – displays the help system for the application. 
• Symprex Web Site – opens your default Internet browser at the Symprex 

Web Site homepage. 
• Symprex Support Page – opens your default Internet browser at the 

Symprex support web page. 
• About – displays the About box for the application. 

2.3.4 Context-Sensitive Menu 

The context-sensitive menu is displayed when an item in the explorer is right-
clicked. The menu contains the following items: 
 

• Group Settings… - displays the Group Settings dialog (see §2.5). 
• Refresh… - refreshes the selected item. 

2.4 Options 

The Options dialog is opened by selecting the File > Options… menu item. The 
following options are available: 
 

• Disable Splash Screen (Registered Version only) – prevents the splash 
screen from being displayed when the application is started. This setting 
only has effect in the registered version of the application. 

• Use Current Profile – when checked, the application will log on your 
Exchange Server using the current mail profile if such a profile is 
currently logged on (for example, if you are using Microsoft Outlook). If a 
profile is not available or this option is not checked, the “Choose Profile” 
dialog is displayed when the application starts. 

• Show Custom Attributes – when selected, the custom attributes are 
displayed for each mailbox. 

• Show System Information – when selected, system information is 
displayed for each mailbox. 

• AutoResize All Rows (Group Settings Dialog) – when selected, resizing 
one row in the grid will cause all rows to be resized to the new height. 
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2.5 Group Settings 

The Group Settings dialog allows you to apply the same settings to a group of 
users. To open it, select the appropriate group and either select the Group > 
Settings… menu item or right-click the node and select Group Settings. 
 

 
 
The grid displays the properties of each mailbox in five sections: 
 

• Mailbox Details 
• Personal Details 
• Business Details 
• Custom Attributes 
• System Information 

 
To edit a property, double-click the appropriate cell in the grid, or select the 
appropriate cell and press F2. Some properties may not be changed; in this 
case, the cell cannot be edited. 
 
When a property of a mailbox has been changed, the property itself is shown in 
red font and the name of the mailbox is displayed in bold as illustrated below. 
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To apply the changes made, click the Update button. The update process can 
be cancelled at any time by clicking the Cancel button. 
 
To set the properties of several mailboxes, check the appropriate check-boxes 
in the left-hand column (you can use the All, None and Invert buttons to adjust 
the selected mailboxes) and click the Edit… button. This will display the Edit 
Group Settings dialog. 
 

 
 
Where properties have the same value amongst all of the selected mailboxes, 
the value will be inserted in to the appropriate text box. Once the changes have 
been made, click the OK button; each changed property will be updated on the 
grid. Note that only properties modified on the dialog will be updated in the grid. 

2.5.1 Export Group Settings 

Clicking the Export… button will display a dialog allowing the contents of the 
grid to be exported to either a plain text file or a Microsoft Excel compatible CSV 
file. 
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Enter the output file in the box at the top of dialog, or click the “…” button to 
select a file. The file may be generated in one of three formats: 
 
Output Format Settings 
Plain text De-select the Write as Comma 

Separated Values format check-box 
CSV (Comma-Separated Values) Select the Write as Comma 

Separated Values format check-box 
Microsoft Excel Select the Convert to Excel 

Spreadsheet on completion 
checkbox, which converts the CSV 
output file to Excel format. 

 
If the output file is in Excel format, the spreadsheet may be opened 
automatically by selecting Open spreadsheet in Excel on completion. 
 
Note Excel 2000 or later must be installed to generate Excel spreadsheets. 
 
To generate the output file, click the Generate button or close the dialog by 
clicking the Cancel button. 

2.5.2 Print Group Settings 

Clicking the Print… button will display a print preview of the grid and allow the 
grid to be printed to any printer available on your system. 
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To adjust the magnification, click the  button, and to print the grid, click 
the  button. 
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3 REQUIRED ACCOUNT PERMISSIONS 
Symprex Mailbox Manager requires the user to be logged on to Windows with a 
domain account that has permissions to update mailbox attributes. 
 
Open Active Directory Users and Computers, then click Advanced Features 
in the View menu. 
 

 
 
You can now assign the required permissions to the user, which you can do on 
domain level or user level. 

3.1.1 Domain Level 

To assign the permissions to allow the user to maintain all account information 
in your domain, open the properties for each user container, then add the user 
and check the advanced rights Read All Properties and Write All Properties 
and apply onto User objects as follows: 
 
In Active Directory Users and Computers, select the appropriate container 
and open Properties. 
 

 
 
Select the Security tab and add the user to grant the permissions to. 
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Click Advanced and find the user in the permission entries list. 
 

 
 
(continued on next page)
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Click View/Edit and select User objects in Apply onto, then: 
 

• Make sure the right Read All Properties is checked 
• Make sure the right Write All Properties is checked 

 

 
 
Click OK to apply the permissions. 
 
Repeat these steps for each user container that holds users with mailboxes in 
the domain. 
 
The user now has the required rights to maintain all account information in the 
domain. 
 
Please note that in installations with multiple domain controllers it will take time 
for rights to replicate between domain controllers. 

3.1.2 User Level 

To assign the permissions to allow the user to edit account information for 
specific individual accounts, open the properties of each of those individual 
accounts, then on the Security tab add the account and check the rights Read 
and Write. 
 
(continued on next page)
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Select an account, open properties, add the user to grant permissions, then: 
 

• Make sure the right Read is checked 
• Make sure the right Write is checked 

 

 
 
The account now has the required rights to maintain account information for the 
selected account. 
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4 CONTACTING SYMPREX 

4.1 Visit Our Web Site 

Our web site provides general information about Symprex and our products: 
http://www.symprex.com/ 
 
If you experience technical problems with one of our products, please visit our 
support page: 
http://www.symprex.com/support.htm 

4.2 Contact Us by Email 

Please email general enquiries about Symprex or our products to: 
info@symprex.com 
 
Please email sales enquiries to: 
sales@symprex.com 
 
Please email support enquiries to: 
support@symprex.com 

4.3 Contact Your Local Reseller 

Symprex has partners and resellers in most countries. You can find your local 
reseller here: 
http://www.symprex.com/resellers.htm 
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