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Introduction 

1 INTRODUCTION 
Symprex Folder Permissions Manager is a powerful application that allows you 
to view and change permissions on folders within individual mailboxes, groups 
and address lists. Common sets of permissions can be stored within templates 
and applied as desired to make repetitive tasks much simpler. Permissions can 
be applied to a folder and its sub folders, or to any set of folders on the server, 
and specified permissions can be appended, replaced, removed or updated. 
 
Symprex Folder Permissions Manager is also the perfect tool for maintaining 
and enforcing permissions on mailboxes and folders according to a defined 
policy. For example, it is easy to ensure that all receptionists have Reviewer 
permissions on all Calendar folders, or that all users have Author permissions 
on all Contact folders. 

1.1 System Requirements 

Symprex Folder Permissions Manager requires: 
 

• When installing on workstation: 
Microsoft Windows NT4 (SP3 or later), 2000, XP or Vista 
Microsoft Outlook 2000, 2002 (SP3 or later), 2003 or 2007 

• When installing on server: 
Microsoft Windows Server NT4 (SP3 or later), 2000 or 2003 
Microsoft Exchange 5.5, 2000, 2003 or 2007 

• 10 MB free hard-disk space 
• 800 x 600 or higher screen resolution 
• Supports use via terminal services on the above listed server platforms 

 
Symprex Folder Permissions Manager can access mailbox and public folders 
on any Exchange 5.5, 2000, 2003 and 2007 server. Please note recommended 
settings for Exchange 2003 and 2007 servers described in §4.1. 

1.2 Permissions Requirements 

Symprex Folder Permissions Manager requires you to be logged on to Windows 
with a domain account that must have certain permissions in the domain and on 
your Exchange server (see §5). 
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2 TUTORIAL 

2.1 Getting Started 

Symprex Folder Permissions Manager is started by clicking its icon in the 
program group. If the application is running in evaluation mode, a window will 
be displayed advising you of the number days remaining in the evaluation 
period. If you have purchased a license, you can enter it by clicking the Enter 
Registration… button. 
 
After the splash screen has been displayed, you may be required to select the 
profile of the Exchange user you wish to connect as. Once successfully logged 
on, the main application window will be opened. 
 
Symprex Folder Permissions Manager requires you to be logged on to Windows 
with a domain account that must have certain permissions in the domain and on 
your Exchange server (see §5). 

2.2 The Main Application Window 

The main application window is split in to two parts. 
 

 
 
The left-hand side of the window displays a tree of your Exchange system, 
including all address lists, distribution lists, mailboxes and folders for each 
mailbox, and the Public Folders. Expanding the nodes (either by double-clicking 
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the node itself or clicking the “+” box to the left of the node) will reveal the 
contents of that node. 
 
Note By default, the application shows all folders within each mailbox. This can 
be modified by the “Only Show Default Folders” option; see §2.4. 
 
The right-hand side of the window displays the permissions for the currently 
selected folder from the Exchange system tree (when a non-folder node is 
selected, the controls will be disabled). 
 
The main list shows the users who have permissions on the selected folder. 
The list may be changed by using the Add and Remove buttons, or you may 
view the properties of an existing user in the list by clicking the Properties 
button. Below the list, the permissions that the selected user has are displayed. 
To change the permissions, either select the pre-defined role from the drop-
down list or set custom properties using the appropriate check boxes. 
 
Check When applying permissions also apply to sub-folders to apply the 
permissions to the currently selected folder and its sub-folders. 
 
Once you are happy with the changes made, click the Apply Permissions to 
Folder button. Alternatively, to restore the original permissions as currently set, 
click the Refresh Folder Permissions button. 
 
Note For a full description of how permissions can be set, see §4.5. 

2.3 Menus 

2.3.1 File Menu 

The File menu contains the following items: 
 

• Options – displays the Options dialog (see §2.4). 
• Exit – closes the application. 

2.3.2 Tools Menu 

The Tools menu contains the following items: 
 

• Apply Permissions to Group – displays the dialog to set the permissions 
of a group of folders (see §2.5). 

• Generate Report – generates a report of the permissions for the selected 
group (see §2.6). 

2.3.3 Templates Menu 

The Templates menu contains the following items: 
 

  Symprex Folder Permissions Manager User’s Guide  │  5



Tutorial 

• Manage Templates – displays the Templates Manager window (see 
§3.1). 

• Apply Template – when an item from the Exchange system tree that can 
have a template applied is selected, this menu item displays the 
Template Manager window is Apply mode (see §3.3). 

2.3.4 Help Menu 

The Help menu contains the following items: 
 

• Contents – displays the help system for the application. 
• Symprex Web Site – opens your default Internet browser at the Symprex 

Web Site homepage. 
• Symprex Support Page – opens your default Internet browser at the 

Symprex support web page. 
• About – displays the About box for the application. 

2.3.5 Context-Sensitive Menu 

The context-sensitive menu is displayed when an item in the explorer is right-
clicked. The menu contains the following items: 
 

• Apply Permissions to Group… – displays the dialog to set the 
permissions of a group of folders (see §2.5). 

• Apply Template… - displays the dialog to apply a template (see §3.3). 
• Manage Templates… - displays the dialog to manage templates (see 

§3.1). 
• Refresh… - refreshes the selected item. 
• Generate Report… – displays the report dialog (see §2.6). 

2.4 Options 

The Options dialog is opened by selecting the File > Options… menu item. The 
following options are available: 
 

• Only Show Default Folders – forces the explorer to only show the default 
Exchange folders within each mailbox. This can be faster than retrieving 
all of the folders within a mailbox. 

• Confirm applying new permissions – makes the application prompt for 
confirmation when new permissions are being applied. 

• Give restored user default rights (Outlook behaviour) – in Microsoft 
Outlook, if a user is removed and then re-added to the list of 
permissions, they are always assigned the default rights. This can be 
annoying if the user had other rights when they were deleted. By de-
selecting this option, the application will restore the original rights for the 
user if they are removed and re-added, but only whilst the changes have 
not been applied. 
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• Disable Splash Screen (Registered Version only) – prevents the splash 
screen from being displayed when the application is started. This setting 
only has effect in the registered version of the application. 

• Use Current Profile – when checked, the application will log on your 
Exchange Server using the current mail profile if such a profile is 
currently logged on (for example, if you are using Microsoft Outlook). If a 
profile is not available or this option is not checked, the “Choose Profile” 
dialog is displayed when the application starts. 

2.5 Apply Permissions to Group 

This dialog allows permissions to be set to a group of folders without the 
requirement to create a template. To open the dialog, select the appropriate 
group and either select the Tools > Apply Permissions to Group… menu item 
or right-click the item and select Apply Permissions to Group. 
 

 
 
The top of the dialog displays the group that will be modified. Select how the 
permissions will be applied from the options at the top of the dialog (see below 
for more information on these options). Then select the folders that will be 
modified from the list of the left of the dialog, and which permissions will be set 
on the right of the dialog. 
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You can choose how permissions will be applied from one of the following 
options: 
 

• Append Mode – only new permissions are added; any existing 
permissions on the folders will remain in place and will not be overwritten 
by the permissions defined in the template. 

• Overwrite mode – all existing permissions (except those of the Default 
and Anonymous users) are removed and overwritten by the permissions 
defined in the template. 

• Overwrite, No Delete mode – all existing permissions are overwritten but 
those not specified in the template will not be removed. 

• Remove – all permissions specified in the list will be removed but other 
existing permissions will not be altered. 

• Update – all permissions defined in the list will be updated but any that 
do not exist will not be created. 

 
Note The permissions for the Default and Anonymous users can be updated 
but if they do exist within the permissions for a folder, they will not be created. 
 
Note For a full description of how permissions can be set, see §4.5. 
 
The three check-boxes at the bottom of the window control are context-sensitive 
to the type of object selected in the explorer. They will be available as follows: 
 
When a Single Mailbox is Selected 
 

• “Preview Modified Mailboxes” is disabled. 
• “Apply to Sub-Folders”; when checked, any user-created folders within 

the selected top-level folders will be modified. 
 
When a Mailbox Group is Selected 
 
NB. A “Mailbox Group” is a generic term for Distribution and Address Lists 
 

• “Preview Modified Mailboxes”; when checked, will cause a list of the 
mailboxes that will be affected by the changes to be previewed in a 
separate window. 

• “Apply to Sub-Groups”; when checked, all child mailbox groups within the 
selected group will be modified. 

• “Apply to Sub-Folders”; when checked, any user-created folders within 
the selected top-level folders will be modified. 

 
When a Public Folder is Selected 
 

• “Preview Modified Folders”; when checked, will cause a list of the folders 
that will be affected by the changes to be previewed in a separate 
window. 
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•  “Apply to Sub-Folders”; when checked, any sub-folders within the 
selected Public Folder will be modified. 

 
To apply the permissions to the objects within the selected group, click the 
Apply Permissions button. To close the dialog without applying any changes, 
click the Cancel button. 

2.6 Report 

The Report dialog is used to generate a file containing the permissions set on 
the objects within the selected group of the explorer. To open the dialog, select 
the appropriate group and either select the Tools > Generate Report… menu 
item or right-click the item and select Generate Report…. 
 

 
 
Enter the output file in the box at the top of dialog, or click the “…” button to 
select a file. The file may be generated in one of three formats: 
 
Output Format Settings 
Plain text De-select the Write as Comma 

Separated Values format check-box 
CSV (Comma-Separated Values) Select the Write as Comma 

Separated Values format check-box 
Microsoft Excel Select the Convert to Excel 

Spreadsheet on completion 
checkbox, which converts the CSV 
output file to Excel format. 

 
 
Note Excel 2000 or later must be installed to generate Excel spreadsheets. 
 
If the output file is in Excel format, the spreadsheet may be opened 
automatically by selecting the Open spreadsheet in Excel on completion 
checkbox. 
 
To generate the output file, click the Generate button or close the dialog by 
clicking the Cancel button. 
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3 TEMPLATES 
The Templates feature of the application allows the administrator to create a set 
of standard permissions to be applied to Mailboxes and Public Folders.  

3.1 The Templates Manager 

The Templates Manager dialog is used to manage your templates. The main 
part of the dialog displays a list of the templates available in the database. The 
view may be changed between icons and a list using the buttons in the toolbar 
at the top of the window. 
 

 
 
The following actions may be performed: 
 

• To create a new template ► click the New button. The Template Wizard 
will be opened in Create mode. 

• To edit an existing template ► select the template from the list, and 
either click the Edit or double-click the template. The Template Wizard 
will be opened in Modify mode. 

• To delete an existing template ► select the template from the list and 
click the Delete button. 

3.2 The Template Wizard 

The Template Wizard is used to either create a new template or modify an 
existing template. The wizard guides you through a series of steps to configure 
the template. At any stage, you may cancel the process by clicking the Cancel 
button to return to the Manager dialog. To proceed to the next step, click the 
Next button, or to return to a previous step, click the Previous button. Once the 
template is correctly configured, the Finish button will become enabled. 
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3.2.1 Welcome 

This step simply welcomes you to the wizard. To prevent it from being displayed 
each time you run the wizard, select the Do not show… check box. 
 
Click the Next button to proceed to the next step. 

3.2.2 Step One – Name and Type of Template 

This step configures the name and type of the template. 
 

 
 
Enter/update the name of the template in the text box at the top of the dialog to 
identify the template in the list. 
 
Choose the type of template from one of the following options: 
 

• Append Mode – only new permissions are added; any existing 
permissions on the folders will remain in place and will not be overwritten 
by the permissions defined in the template. 

• Overwrite mode – all existing permissions (except those of the Default 
and Anonymous users) are removed and overwritten by the permissions 
defined in the template. 

• Overwrite, No Delete mode – all existing permissions are overwritten but 
those not specified in the template will not be removed. 

• Remove – all permissions specified in the list will be removed but other 
existing permissions will not be altered. 
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• Update – all permissions defined in the list will be updated but any that 
do not exist will not be created. 

 
Click the Next button to proceed to the next step. 

3.2.3 Step Two – Modified Objects 

This step configures the objects that can be modified by the template. 
 

 
 
Select the appropriate option for the template depending on whether the 
template should alter Mailboxes only, Public Folders only, or both Mailboxes 
and Public Folders. Your selection here will determine which folders are 
available in Step Three. 

3.2.4 Step Three – Configure Folders and Permissions 

This step configures which folders the template will alter and what permissions 
are applied to those folders (see dialog top of next page). 
 
Select the folders that the template should alter from the list of the left-hand side 
of the dialog. If the same permissions are going to be applied to all selected 
folders, select the Apply the same permissions to all selected folders check 
box. If this check box is unchecked, you must set the permissions individually 
for each selected folder. 
 

  Symprex Folder Permissions Manager User’s Guide  │  12



Templates 

 
 
On the right-hand side of the dialog, the permissions that will be set for each 
folder are displayed. These controls work exactly like the controls on the main 
window, except the Apply… and Refresh… buttons are not available. 
 
Note The Default and Anonymous users can be modified by the template but if 
they do not exist, they will not be created. 
 
Note For a full description of how permissions can be set, see §4.5. 
 
Click the Next button to proceed to the next step. 

3.2.5 Ready to Create/Update Template 

This final step confirms you want to create or update the template you have 
been working on. If you are happy, click the Finish button. Alternatively, you 
may return to any previous step by clicking the Previous button. 

3.2.6 Finished! 

The template has been created or updated. Click the Close button to close the 
wizard and return to the Template Manager window. 

3.3 Applying a Template 

To apply a template to a mailbox, distribution list, address list or Public Folders, 
select the appropriate node in the Exchange system tree of the main application 
window and click the Templates > Apply Template… menu item, or right-click 
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the node and select Apply Template…. This will open the Templates Manager 
dialog in Apply mode. 
 

 
 
The three check-boxes at the bottom of the window control are context-sensitive 
to the type of object selected in the explorer. They will be available as follows: 
 
When a Single Mailbox is Selected 
 

• “Preview Modified Mailboxes” is disabled. 
• “Apply to Sub-Folders”; when checked, any user-created folders within 

the selected top-level folders will be modified. 
 
When a Mailbox Group is Selected 
 
NB. A “Mailbox Group” is a generic term for Distribution and Address Lists 
 

• “Preview Modified Mailboxes”; when checked, will cause a list of the 
mailboxes that will be affected by the changes to be previewed in a 
separate window. 

• “Apply to Sub-Groups”; when checked, all child mailbox groups within the 
selected group will be modified. 

• “Apply to Sub-Folders”; when checked, any user-created folders within 
the selected top-level folders will be modified. 

 
When a Public Folder is Selected 
 

• “Preview Modified Folders”; when checked, will cause a list of the folders 
that will be affected by the changes to be previewed in a separate 
window. 
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•  “Apply to Sub-Folders”; when checked, any sub-folders within the 
selected Public Folder will be modified. 

 
To apply a template, select it from the list and click the Apply button. After 
confirming the action, the application will apply the template to the selected 
item. Bear in mind this can be a long process for distribution lists and address 
lists with several entries. The progress is displayed in a bar at the bottom-right 
of the window. 
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4 MISCELLANEOUS ISSUES 
This section describes miscellaneous issues that relate to the operation of the 
application. 

4.1 Exchange 2003/2007 Additional Information 

Exchange 2003/2007 limits how many times specific objects on the server can 
be opened per session when using the MAPI interface. Two of these limits 
affect Folder Permissions Manager because the default values are very low. 
 
To resolve this problem, you can add a registry key that changes the limits that 
affect Folder Permissions Manager. The new limits override the default limits of 
the server objects in question. 
 
Warning If you use Registry Editor incorrectly, you may cause serious 
problems that may require you to reinstall your operating system. Symprex 
cannot guarantee that you can solve problems that result from using Registry 
Editor incorrectly. You use it at your own risk. 
 
To add a registry key that change the limits, which affects Folder Permissions 
Manager, follow these steps: 
 

1. Click Start, click run, type regedit, and then click OK. 
2. Expand the following registry subkey of HKEY_LOCAL_MACHINE: 

 

\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem 
 

3. Right-click ParametersSystem, point to New, and then click Key. 
4. Type MaxObjsPerMapiSession, and then press ENTER to name the 

new subkey. 
5. Right-click MaxObjsPerMapiSession, click New, and then click 

DWORD Value. 
6. Type objtFolder, and then press ENTER to name the object. 
7. Right-click objtFolder, and then click Modify. 
8. In the Value data box, select Hexadecimal as Base, then type 1000, 

and then click OK. 
9. Right-click MaxObjsPerMapiSession, click New, and then click 

DWORD Value. 
10. Type objtACLView, and then press ENTER to name the object. 
11. Right-click objtACLView, and then click Modify. 
12. In the Value data box, select Hexadecimal as Base, then type 100000, 

and then click OK. 
 
Note These settings are not required, but are recommended to be set. 
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4.2 Outlook 2000 Additional Information 

A problem in the original release version of Outlook 2000 may prevent users 
from viewing folders as expected when permissions have been manipulated 
using third-party applications. Symprex Folder Permissions Manager1 is not 
affected by this issue and is fully compatible with all versions of Outlook. 

4.3 Public Folders and the Owner User 

To prevent the contents of a Public Folder from becoming inaccessible, Folder 
Permissions Manager prevents the removal of the rights Folder Owner, Folder 
Visible and Edit Own Items for the Owner user of a Public Folder who created 
the particular folder. This behaviour is consistent with Outlook. 

4.4 Read-Only Public Folders 

You will not be able to modify the permissions on some Public Folders, and in 
some cases, you will not be able to review the permissions. This is a limitation 
of Outlook and not an intentional restriction of the application. 
 
When previewing modified folders in either the Apply Permissions to Group 
dialog or Apply Template dialog, read-only folders will not be included in the list. 

4.5 Setting Folder Permissions 

This section describes how to set permissions on folders using the various 
dialogs in the application. These windows are the Main window (§2.2), the 
Template Wizard window (§3.2.4), and the Group Permissions window (§2.5). 

4.5.1 Name/Role 

Displays user names and their permissions for the folder. The default 
permission is the role granted to all general users. 
 
Next to Name/Role box, the following buttons are available: 
 

• Add – Selects user, distribution list, and public folder names to add to the 
Name/Role box. 

• Remove – Removes the selected name from the Name/Role box. 
• Properties –  Displays details about the selected name. 

4.5.2 Permissions 

Specifies a role for the selected name. When you select a role, the permissions 
associated with that role are automatically selected. When you select individual 
permissions, the matching role name appears in the Roles box. If there is no 

                                            
1 Symprex Folder Permissions Manager version 3.5 and later. 
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matching role, Custom appears. You cannot select Custom; it appears 
automatically. 

4.5.3 Roles 

Specifies a role for the selected name in the Name/Role box. 
 
Role Description 
Owner Grants all permissions in the folder. Create, read, 

modify, and delete all items and files and create 
subfolders. The owner can also change permission 
levels that others have for the folder. 

Publishing Editor Grants permission to create, read, modify and delete 
all items and files, and create subfolders. 

Editor Grants permission to create, read, modify, and delete 
all items and files. 

Publishing Author Grants permission to create and read items and files, 
modify and delete items and files you create, and 
create subfolders. 

Author Grants permission to create and read items and files, 
and modify and delete items and files you create. 

Nonediting Author Grants permission to create and read items and files.  
Reviewer Grants permission to read items and files only. 
Contributor Grants permission to create items and files only. The 

contents of the folder do not appear. 
None Grants no permission in the folder. Use this as the 

default permission when you want to limit the folder 
audience to only users you specifically add to the 
Name/Role box. 

4.5.4 Individual Permissions 

The following table describes the effect of each individual permission that can 
be set. 
 
Permissions Description 
Create Items Grants permission to post items in the folder. 
Read Items Grants permission to open any item in the folder. 
Create Subfolder Grants permission to create subfolders in the folder. 
Folder Owner Grants all permissions in the folder. 
Folder Contact Grants folder contact status. Folder contacts receive 

automated notifications from the folder, such as 
replication conflict messages, as well as requests from 
users for additional permissions or other changes in the 
folder. 

Folder Visible Grants permission to see the folder. 
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4.5.5 Edit Items 

Select one of the following options. 
 
Option Description 
None Does not allow changes to any item. 
Own Allows you to modify items you create. 
All Allows you to modify any item. 

4.5.6 Delete Items 

Select one of the following options. 
 
Option Description 
None Does not allow you to delete any item. 
Own Allows you to delete items you create. 
All Allows you to delete any item. 
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5 REQUIRED ACCOUNT PERMISSIONS 
Symprex Folder Permissions Manager requires you to be logged into Windows 
with a domain account that has permissions on Exchange 5.5, 2000, 2003 and 
2007, and in the domain, as described below. 

5.1 Exchange 5.5 Account Permissions 

To make sure your account has the necessary permissions on Exchange 5.5, 
follow these steps: 
 
Step 1 
 
Open Microsoft Exchange Administrator, then: 
 

• Open the Options dialog from the Tools menu. 
• Make sure that the Display rights for roles on Permissions page is 

checked. 
 

 
 
Step 2 
 
Click the domain container, then: 
 

• Open the Properties dialog from the File menu. 
 
(see dialog top of next page) 
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Step 3 
 
Select the Permissions tab in the domain properties dialog, then, for your 
account: 
 

• Make sure Mailbox Owner is checked. 
• Make sure Logon Rights is checked. 

 

 
 
Step 4 
 
Finally: 
 

• Your account must be a member of the Domain Admins group. 
 
Your account now has the required permissions. 
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5.2 Exchange 2000/2003 Account Permissions 

To make sure your account has the necessary permissions on Exchange 2000 
or 2003, follow these steps: 
 
Note If your account is a member of the Domain Admins group, and it is not a 
member of any of the Exchange security groups installed with Exchange server, 
it will already have the necessary permissions by inheritance. 
 
Step 1 
 
Open Exchange System Manager, then: 
 

• Select your server (or mailbox store). 
• Right-click and select Properties to open the Properties dialog. 

 
Step 2 
 
Select the Security tab in the server (or mailbox store) properties dialog, then: 
 

• Add or select your account. 
• Allow the Administer information store right. 

 

 
 
Repeat the above steps for appropriate servers (or mailbox stores) as required. 
 
Your account now has the required permissions. 
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5.3 Exchange 2007 Account Permissions 

To make sure your account has the necessary permissions on Exchange 2007, 
follow these steps: 
 
Note If your account is a member of the Domain Admins group, and it is not a 
member of any of the Exchange security groups installed with Exchange server, 
it will already have the necessary permissions by inheritance. 
 
Step 1 
 
Open the PowerShell, then: 
 

• Assign your account the Administer information store right on your 
server (or mailbox store) by executing one of the following commands: 
 
To assign the right on your server: 
 
Get-MailboxServer "YourServer" |  
add-adpermission -user "YourAccount" -extendedrights  
ms-Exch-Store-Admin 
 
To assign the right on your mailbox store: 
 
Get-MailboxDatabase "YourServer\YourMdb" |  
add-adpermission -user "YourAccount" -extendedrights  
ms-Exch-Store-Admin 
 
Note that you need to replace YourServer with the name of your server, 
YourMdb with the name of your mailbox store, and YourAccount with 
the account you want to assign the right. 

 
Repeat the above steps for appropriate servers (or mailbox stores) as required. 
 
Your account now has the required permissions. 
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6 CONTACTING SYMPREX 

6.1 Visit our Web Site 

Our web site provides general information about Symprex and our products: 
http://www.symprex.com 
 
If you experience technical problems with one of our products, please visit our 
support page: 
http://www.symprex.com/support 

6.2 Contact us by e-mail 

Please e-mail general enquiries about Symprex or our products to: 
info@symprex.com 
 
Please e-mail sales enquiries to: 
sales@symprex.com 
 
Please e-mail support enquiries to: 
support@symprex.com 

6.3 Contact your local reseller 

Symprex has partners and resellers in most countries. You can find your local 
reseller here: 
http://www.symprex.com/resellers 
 

http://www.symprex.com/
http://www.symprex.com/support
mailto:info@symprex.com
mailto:sales@symprex.com
mailto:support@symprex.com
http://www.symprex.com/resellers
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