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Introduction

1 INTRODUCTION

Using the AutoArchive feature in Outlook is a cheap and efficient way to archive
email and other Outlook data. However, there is no easy, built-in way to set the
AutoArchive settings globally on all mailbox folders on Exchange server.

Symprex AutoArchive Manager is a solution to this problem. Using AutoArchive
Manager you can update the AutoArchive settings on all mailbox folders in your
Exchange installation, both manually for individual mailboxes and automatically
for groups of mailboxes (distribution lists and address lists). You can also easily
review settings and generate reports of settings.

A command-line utility is also included to enable AutoArchive for each user and
to set the Outlook AutoArchive application options. This utility can be used from
your login script. Note that these options can also be set via group policies.

In short Symprex AutoArchive Manager is the perfect tool to enforce archiving in
your Exchange environment at a low cost.

1.1 System Requirements

Symprex AutoArchive Manager requires:

e When installing on workstation:
Microsoft Windows 2000, XP or Vista
Microsoft Outlook 2000, 2002, 2003 or 2007

e \When installing on server:
Microsoft Windows Server 2000, 2003 or 2008
Microsoft Exchange Server 2000, 2003 or 2007

e 10 MB free hard-disk space
e 800 x 600 or higher screen resolution
e Supports terminal services on the above listed server platforms

Symprex AutoArchive Manager can access mailbox folders on any Exchange
2000, 2003 and 2007 server. Please note the recommended settings for
Exchange 2003 and 2007 servers described in §4.1.

To get the best results using Outlook AutoArchive it is recommended that you
keep Outlook updated with the latest service packs from Microsoft.

1.2 Permissions Requirements
Symprex AutoArchive Manager requires you to be logged on to Windows with a

domain account that must have certain permissions in the domain and on your
Exchange server (see §5).

Symprex AutoArchive Manager User’'s Guide | 3



Introduction

1.3 About Outlook AutoArchive

This section includes important information about how Outlook AutoArchive
works.

1.3.1 Description of the AutoArchive Feature in Outlook

The following articles from the Microsoft Knowledge Base provide a detailed
description of the AutoArchive feature in each Outlook version:

e Description of the AutoArchive feature in Outlook 2007 and 2003
http://support.microsoft.com/kb/830119

e Description of the AutoArchive feature in Outlook 2002
http://support.microsoft.com/kb/290847

e Description of the AutoArchive feature in Outlook 2000
http://support.microsoft.com/kb/239652

Symprex recommends you keep up to date with issues and information that is
related to Outlook AutoArchive on Microsoft’s support web site.

1.3.2 Items are not Archived as Expected in Outlook

It is important to understand that Outlook may not appear to archive items as
expected. This is because the date that is used to determine when an item is
archived depends on the type of item.

It is highly recommended that you carefully read the following article from the
Microsoft Knowledge Base:

e |tems are not archived as expected when you use the Archive or
AutoArchive features in Outlook
http://support.microsoft.com/kb/260217

Symprex recommends you keep up to date with issues and information that is
related to Outlook AutoArchive on Microsoft's support web site.
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Tutorial

2 TUTORIAL

2.1 Getting Started

Symprex AutoArchive Manager is started by clicking its icon in the Windows
program group. If the application is running in evaluation mode, a window will
be displayed advising you of the number days remaining in the evaluation
period. If you have purchased a license, you can enter it by clicking the Enter
Registration... button.

After the splash screen has been displayed, you may be required to select the
profile of the Exchange user you wish to connect as. Once successfully logged
on, the main application window will be opened.

Symprex AutoArchive Manager requires you to be logged on to Windows with a

domain account that must have certain permissions in the domain and on your
Exchange server (see §5).

2.2 The Main Application Window

The main application window is split in to two parts.

& Symprex AutoArchive Manager 10| =]

File  Tools Help

- —&toArchive Setti
=@ Address Lists EHSHETHS ST

Global Address List {~ Do not archive items in this folder

- [ Al Address Lists " Archive items in this folder using the default settings

- (B &0 Contacts (this setting disables archiving in Outlook 97 to 2000)
[] H

~BE Al Uzers f+ Archive this folder using these seftings:

ﬁ Adminiztrator Clean out tems older than IB jl IMnnths vl

= €% Alex Hawkins . !
= {~ Move old tems to default archive folder
(results in below setting in Outlook 97 to 20000

| »

+ Move old tems to:

i L WA RCHYEWHYWAar chive pat Browwse. . |

" Permanently delete old tems

----- S Outbox )
..... ﬁ Sent ltems Apply Mewe Settings Refrezh |
----- @ Tasks

[+ ﬁ Ann Miller — Application Settings

& Ben Adams Ising Qutiook 2002/2003:2007 Default Autodrchive Settings

- % Dave Wilson LI

| Feady | 4

The left-hand side of the window displays a tree of your Exchange system,
including all address lists, distribution lists, mailboxes and folders for each
mailbox (excluding any folders that contain Contact items).

Note By default, the application shows all folders within each mailbox. This can
be modified by the “Only Show Default Folders” option; see §2.4.
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The right-hand side of the window displays the AutoArchive settings for the
currently selected folder from the Exchange system tree (when a non-folder
node is selected, the controls will be disabled). The controls of the settings
resemble those found on the “AutoArchive” tab of the Property pages for a
folder in Outlook.

To disable the mechanism for the folder, select the Do not archive items in
this folder option.

To enable the mechanism for the folder, either select the Archive items in this
folder using the default settings option, which enables the mechanism for all
users of Outlook 2000/2003/2007 using the default user settings, but disables
the mechanism for all Outlook 2000 users, or select the Archive this folder
using these settings option, which is valid for all versions of Outlook.

When the Archive this folder using these settings option is selected, you
must specify when and how the items must be archived. Set the period using
the up and down arrows, and set the period granularity using the drop-down list.
If the items are to be moved to a PST file, select the Move old items to default
archive folder option, or the Move old items to option and enter the name of
the file. Click the Browse button to locate a suitable file. Alternatively, select the
Permanently delete old items option to have the items deleted from the folder.

Note See §3.4 for more details about the archive path and file name.

Once you are happy with the changes made, click the Apply New Settings
button. Alternatively, to restore the original settings as currently set, click the
Refresh button.

By default AutoArchive Manager uses the default AutoArchive settings used in
Outlook 2002/2003/2007. You can change this in the Options dialog so that the

default AutoArchive settings of Outlook 2000 are used instead. The value of this
setting is shown below the AutoArchive settings frame.

2.3 Menus

2.3.1 File Menu

The File menu contains the following items:

e Options — displays the Options dialog (see §2.4).
e Exit — closes the application.

2.3.2 Tools Menu

The Tools menu contains the following items:

e Apply Group Settings — displays the dialog to apply settings to a group of
folders (see §2.5).
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Generate Report — generates a report of the settings for the selected
group (see §2.6).

2.3.3 Help Menu

The Help menu contains the following items:

Contents — displays the help system for the application.

Symprex Web Site — opens your default Internet browser at the Symprex
Web Site homepage.

Symprex Support Page — opens your default Internet browser at the
Symprex support web page.

About — displays the About box for the application.

2.3.4 Context-Sensitive Menu

The context-sensitive menu is displayed when an item in the explorer is right-
clicked. The menu contains the following items:

Apply Settings to Group... — displays the dialog to apply settings to a
group of folders (see §2.5).

Refresh... - refreshes the selected item.
Generate Report — displays the report dialog (see §2.6).

2.4 Options

The Options dialog is opened by selecting the File > Options... menu item. The
following options are available:

Only Show Default Folders — forces the explorer to only show the default
Exchange folders within each mailbox. This can be faster than retrieving
all of the folders within a mailbox.

Use Outlook 2000 AutoArchive Default Settings — select this option to
use Outlook 2000 default AutoArchive settings. By default the application
uses Outlook 2002/2003/2007 default AutoArchive settings.

Disable Splash Screen (Registered Version only) — prevents the splash
screen from being displayed when the application is started. This setting
only has effect in the registered version of the application.

Use Current Profile — when checked, the application will log on your
Exchange Server using the current mail profile if such a profile is
currently logged on (for example, if you are using Microsoft Outlook). If a
profile is not available or this option is not checked, the “Choose Profile”
dialog is displayed when the application starts.

2.5 Apply Settings to Group

This dialog allows permissions to be set on a group of folders (see next page).
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To open the dialog, select the appropriate group and either select the Tools >
Apply Permissions to Group... menu item or right-click the item and select
Apply Permissions to Group.

#§ Apply Group Settings |

Thiz window alloves you to apply common settings to a group of mailkboxes, The filename

&

can contain the following tokens:

Fomailox % - substituted for the mailbox name

Ffolderss - substituted for the folder name

Selected Group: Global Address List

Folders ta be modified:
Mzl Falders:

Settings for each modified folder:

—Autatrchive Settings

{~ Do not archive tems in this folder

=

D @ Deleted ftems = Archive items in this folder using the default settings

%'”W (this sefting dizables archiving in Qutlook 97 to 2000)

Jourral

Nl:ltes {* Archive thiz folder using these settings:

B outbox Clean out items older than |6 —l Manths -
=]

ﬁSent ftems {~ Mave old tems ta defautt archive folder

B Tasks (results in below setting in Outlook 97 to 20007

r Also apply settings to * Maove old tems to:

user folders

Browsze... |

IL:L&RCHIVEI%maiIbe%Iarchive.pst
User folders contalning
raail e s will oply be
wpdated if the “Inbox”
folder is selected.

{~ Permanently delete old tems

[~ Disakle mechanism for folders but preserve other settings

Apply Cancel |

|Ready |

On the left-hand side of the dialog, select the folders that you wish to modify.
You may choose default folders and/or all user folders (there is no method to
specify individual user folders). Then configure the settings for the folders using
the controls on the right-hand side of the dialog.

If you wish to only disable the mechanism for each selected folder but preserve
all other settings, check the Disable mechanism for folders but preserve
other settings checkbox. This will switch off the mechanism (i.e. effectively
check the Do not archive items in this folder option) whilst leaving any other
settings unaltered for each selected folder.

The file name for the PST file, where archived items will be saved to, can be
customized on a per mailbox/folder basis. This is useful if you wish to archive
the items to a central server. To make a customized file name, use the tokens
described at the top of the dialog (i.e. %emailbox% to be substituted by mailbox
name, and %folder% to be substituted by folder name). Alternatively, leave it
blank to use the Outlook default.

Note See §3.4 for more details about the archive path and file name.

Once you are happy with the settings, click the Apply button to apply the
changes, or click the Cancel button to close the dialog.
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2.6 Report

The Report dialog is used to generate a file containing the permissions set on
the objects within the selected group of the explorer (see dialog top of next

page).

To open the dialog, select the appropriate group and either select the Tools >
Generate Report... menu item or right-click the item and select Generate
Report....

4 Generate Repork x|

Thiz window alloves you to export the permizssions for the
‘ ohjects within a group. The file can either be plain-text,
Comma-Separated Yalues (C5Y) or an Excel speadshest .

Selected Group:  Global Address List

Output File: | _|

v write as Comma-Separated Values (C5Y) format

[¥ Convert to Excel spreadshest on completion

[¥ Open spreadsheet in Excel on completion

cors_|

|Ready |

Enter the output file in the box at the top of dialog, or click the “...” button to
select a file. The file may be generated in one of three formats:

Output Format Settings

Plain text De-select the Write as Comma
Separated Values format check-box
CSV (Comma-Separated Values) | Select the Write as Comma
Separated Values format check-box
Microsoft Excel Select the Convert to Excel
Spreadsheet on completion
checkbox, which converts the CSV
output file to Excel format.

Note Excel 2000 or later must be installed to generate Excel spreadsheets.

If the output file is in Excel format, the spreadsheet may be opened
automatically by selecting the Open spreadsheet in Excel on completion
checkbox.

To generate the output file, click the Generate button or close the dialog by
clicking the Cancel button.
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3 REFERENCE

3.1 What does AutoArchive Manager do?

The AutoArchive Manager application allows a system administrator to centrally
configure the AutoArchive settings on all, or individual, folders within mailboxes.
The tutorial in §2 explains how to use AutoArchive Manager and how to apply
AutoArchive folder settings on individual mailboxes or on groups of mailboxes.

The general Outlook AutoArchive Options for each user/mailbox cannot be set
from within the AutoArchive Manager. This is because this information is not
stored on Exchange server, but in the registry and Outlook profile for each user.

To administratively configure the general Outlook AutoArchive Options you can
use the AutoArchive Manager command-line utility as explained in §3.2 below,
or you can use group policies (see the appropriate Microsoft resources for more
information).

3.2 What does the AutoArchive Manager Command-line Utility
do?

AutoArchive Manager cannot activate the AutoArchive mechanism for a user, or
set any of the Outlook AutoArchive Options found in the Outlook Options dialog.
This needs to be done either locally on a machine when the appropriate user is

logged on or via group policies (please see the appropriate Microsoft resources

for more information).

The most important Outlook AutoArchive Options are:

e Enable/disable AutoArchive

e Number of days between AutoArchiving

e Prompt before AutoArchive

e Delete expired items when AutoArchiving (e-mail folders only)
e Default archive file

§3.2.1 explains how to use the command-line utility, while §3.2.2 provides some
examples, and §3.2.3 describes how to register the command-line utility using
your license key for AutoArchive Manager.

3.2.1 Command-Line Utility Usage

The AutoArchive Manager command-line utility is a small executable file named
aaconfig.exe, which is installed together with AutoArchive Manager. The utility
can be used from a login script or via netlogon. If you run aaconfig.exe without
any arguments it will show instructions on how to use it.
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The AutoArchive Manager command-line utility takes an argument identifying
the profile you wish to update (for the user that is currently logged in) and then
arguments corresponding to the Outlook AutoArchive Options:

aaconfig /profile=name [/enable=on/off] [/days=n] [/prompt=0on/off]
[/delete=on/off] [/arcordelold=on/off] [/showarcfolder=on/off]
[/defperiod=months/weeks/days] [/defgranul=n] [/[defmethod=move/delete]
[/newpstformat=preferunicode/preferansi/enforceunicode/enforceansi]
[/path=path] [/silent]

Where
[profile Outlook profile name (specify * for default profile).
/enable Archive enabled setting.
/days Archive every days setting.
/prompt Prompt before AutoArchive setting.
/delete Delete expired items when archiving (e-mail folders only) setting.
/arcordelold Archive or delete old items setting 1).
/showarcfolder Show archive folder in folder tree setting 1).
/defperiod Default period setting 1).
/defgranul Default archive granularity setting 1).
/defmethod Default method setting 1).
/newpstformat  New PST format 2).
/path Default archive path setting.
[silent Silent mode.

1) Outlook 2002 and later only. 2) Outlook 2003 and later only.

The command-line utility will not run in silent mode until it has been registered.

3.2.2 Command-Line Utility Examples

To set the AutoArchive settings of the default profile to auto-archive enabled,
every 30 days, no prompt, delete expired items, and the default path and file
name to m:\archives\usr_xxx.pst, run the following command (on one line):

aaconfig /profile=* /enable=on /days=30 /prompt=0off /delete=on
/path=m:\archives\usr_xxx.pst /silent

To set the AutoArchive settings of the profile Outlook Profile to auto-archive
enabled, every 7 days, no prompt, delete expired items, and default path and
file to M:\User Archives\usr_xxx.pst, run the following command (on one line):

aaconfig /profile="Outlook Profile" /enable=on /days=30 /prompt=off /delete=on
/path="M:\User Archives\usr_xxx.pst"

In the above example, note the quotes around names containing spaces.

3.2.3 Command-Line Utility Registration

To register the aaconfig.exe command-line utility, simply run it on the machine
where you have registered AutoArchive Manager. A file called aaconfig.lic will
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be created in the same directory aaconfig.exe is run from (make sure you have
write permissions to this directory).

3.3 How to manually configure AutoArchive via Outlook

3.3.1 To Turn on AutoArchive for a Mailbox via Outlook

To manually turn on AutoArchive for a mailbox via Outlook, you must do the
following:

1. On the Tools menu, click Options, and then click the Other tab.
2. Click AutoArchive to open the AutoArchive options dialog.

AutoArchive ﬂﬂ
v Aukoarchive every |14 j days

¥ Prompt before Autodrchive
[ Delete expired items when AutoArchiving (e-mail Folders only)

Default archive file;
IL:'l,OutIu:u:uk Archives\aHW archive.pst Browse, ., |

To specify more detailed Autodrchive settings, right-click on each Falder and
choose Properties, then go to the Autoarchive tab.,

oK I Cancel |

NB. Dialog from Outlook 2000. Later versions include additional options.

3. Click to select the AutoArchive Every check box, and then specify how
often the AutoArchive process will run by typing a number in the days
box.

4. Click to select the Prompt Before AutoArchive check box, if you want
to be notified before the items are archived.

5. In the Default archive file box, type a file name for the archived items to
be transferred to, or click Browse to select from a list.

6. Click OK twice to close Options.

AutoArchive Manager is unable to perform the actions described in this section.
To administratively set these settings you must use the AutoArchive Manager
command-line utility, which comes with AutoArchive Manager, as explained in
§3.2 above (using the command-line utility, for example, during a login script).

3.3.2 To Set AutoArchive Properties for a Folder Manually in Outlook

To manually set AutoArchive properties for a folder in Outlook, you must do the
following:

1. In the Folder List, right-click the folder that you want to AutoArchive, and
then click Properties on the shortcut menu.
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2. Click the AutoArchive tab to see the AutoArchive settings.

Calendar Properties d |
Administration I Farms | Permissions |
General I Home Page Butosrchive

V¥ Clean out items older than IE' :II IMonths VI

&' Move old items ko

IL:'l,OutIu:u:uk Archives\aHW archive.pst Browse, .. |

" Permanently delete old items

oK I Zancel | fpply | Helm

Reference

NB. Dialog from Outlook 2000. Later versions include additional options.

3. To set AutoArchive for this folder, click to select Clean out items older

than.

4. To specify when items should be automatically transferred to your

archive file, type a number in the Months box.

5. To specify a file for the archived items to be transferred to, click Move

old items to.

6. Inthe Move old items to box, type a file name for the archived items, or

click Browse to select from a list, and then click OK.

AutoArchive Manager allows the administrator to centrally perform the actions
described in this section. AutoArchive Manager can even change these settings
on any number of mailboxes, and on any selected folder types, in one step.

3.4 The Archive Path

When AutoArchive is first enabled for a folder in Outlook itself, a default PST file
name is specified. Symprex AutoArchive Manager can not display this file name
and in this case the file name is instead displayed as “<Using Outlook Default>".

Normally you will want to specify a path to a shared network location, which is
accessible to users that run Outlook (and therefore AutoArchive). To leave the
setting as its default, empty the text box, which will re-instate the default setting.
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4 MISCELLANEOUS ISSUES

This section describes miscellaneous issues that relate to the operation of the
application.

4.1 Exchange 2003/2007 Additional Information

Exchange 2003/2007 limits how many times specific objects on the server can
be opened per session when using the MAPI interface. One of these limits
affects AutoArchive Manager because the default value is very low.

To resolve this problem, you can add a registry key that changes the limit that
affects AutoArchive Manager. This limit overrides the default limit of the server
object in question.

Warning If you use Registry Editor incorrectly, you may cause serious
problems that may require you to reinstall your operating system. Symprex
cannot guarantee that you can solve problems that result from using Registry
Editor incorrectly. You use it at your own risk.

To add a registry key that change the limit, which affects AutoArchive Manager,
follow these steps:

1. Click Start, click run, type regedit, and then click OK.

2. Expand the following registry subkey of HKEY LOCAL_MACHINE:
\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

3. Right-click ParametersSystem, point to New, and then click Key.

4. Type MaxObjsPerMapiSession, and then press ENTER to name the
new subkey.

5. Right-click MaxObjsPerMapiSession, click New, and then click
DWORD Value.

6. Type objtFolder, and then press ENTER to name the object.
Right-click objtFolder, and then click Modify.

8. In the Value data box, select Hexadecimal as Base, then type 1000,
and then click OK.

~

Note This setting is not required, but is recommended to be set.
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5 REQUIRED ACCOUNT PERMISSIONS

Symprex AutoArchive Manager requires you to be logged into Windows with a
domain account that has permissions on Exchange as described below.

5.1 Exchange 2000/2003 Account Permissions

To make sure your account has the necessary permissions on Exchange 2000
or 2003, follow these steps:

Note If your account is a member of the Domain Admins group, and not of any
of the Exchange security groups, it already has the necessary permissions.

Step 1
Open Exchange System Manager, then:

e Select your server (or mailbox store).
¢ Right-click and select Properties to open the Properties dialog.

Step 2
Select the Security tab in the server (or mailbox store) properties dialog, then:

e Add or select your account.
e Allow the Administer information store right.

Repeat the above steps for appropriate servers (or mailbox stores) as required.

Your account now has the required permissions.

5.2 Exchange 2007 Account Permissions

To make sure your account has the necessary permissions on Exchange 2007,
follow these steps:

Note If your account is a member of the Domain Admins group, and not of any
of the Exchange security groups, it already has the necessary permissions.

Step 1
Open Exchange System Manager, then:

e Assign your account the Administer information store right on your
server (or mailbox store) by executing one of the following commands:
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To assign the right on your server:

Get-MailboxServer "YourServer" |

add-adpermission -user "YourAccount" -extendedrights
ms-Exch-Store-Admin

To assign the right on your mailbox store:

Get-MailboxDatabase "YourServer\YourMdb" |
add-adpermission -user "YourAccount" -extendedrights
ms-Exch-Store-Admin

Note that you need to replace YourServer with the name of your server,

YourMdb with the name of your mailbox store, and YourAccount with
the account (domain\account) you want to assign the right.

Repeat the above steps for appropriate servers (or mailbox stores) as required.

Your account now has the required permissions.

Symprex AutoArchive Manager User’'s Guide | 16



Contacting Symprex

6 CONTACTING SYMPREX

6.1 Visit Our Web Site

Our web site provides general information about Symprex and our products:
http://www.symprex.com

If you experience technical problems with one of our products, please visit our
support page:
http://www.symprex.com/support

6.2 Contact Us by Email

Please email general enquiries about Symprex or our products to:
info@symprex.com

Please email sales enquiries to:
sales@symprex.com

Please email support enquiries to:
support@symprex.com

6.3 Contact Your Local Reseller

Symprex has partners and resellers in most countries. You can find your local
reseller here:
http://www.symprex.com/resellers
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